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1. Introduction

1.1 Hynesim components

Hynesim is a distributed application. It is made of a master server called hynesim-master, which manages all com-

munications between hynesim-node servers used to virtualize, simulate and emulate the entities defined in a topology.

When hyneview (hynesim’s graphical user interface) sends orders to the nodes, information goes first through hynesim-

glacier, which works as a relay between graphical interfaces and hynesim-master; this information is then relayed by

hynesim-master, which redirects it to its different nodes.

Figure 1.1: hynesim components

1.2 Getting started with Hyneview

1.2.1 Installation

Debian

Make sure you’re on the administration network of your platform and that repository.hns-platform.com resolves
correctly to your local mirrors.

Add the repository key to your package manager using the following command

wget -q http://repository.hns-platform.com/hynesim-pro/3.0/hynesim.asc -O- | apt-key add -
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You can now add this link to your sources (/etc/apt/sources.list):

deb http://repository.hns-platform.com/hynesim-pro/3.0 buster main backports dependencies

You then need to run apt-get update and apt-get install hyneview wireshark. You should allow non root

users to capture packets if you want live captures to work without root access.

Windows

To install Hyneview on Windows, just copy the exe and run it. The exe can usually be found at http://repository.
hns-platform.com/hynesim-pro/3.0/hnvp.exe

1.2.2 Connection

When hyneview starts, a login window asks you to enter the server address and your username/password. The default

one is admin/admin. Then click connect. Check the box “Save” to keep the server’s name for the next time you connect.

The box “Remember me” saves your login and password. If you want to open this window at any time, go to Account →

Connect (Shortcut: CTRL+SHIFT+K).

Figure 1.2: connection window

You can see some information about your connection on the bottom left corner, as well as the button to disconnect

(Shortcut: CTRL+D).

Figure 1.3: connection status

If you want to change your username/password, go to Account → Settings to change your name and/or password. If

you want to generate a random one, click on the wand next to the textbox.
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Figure 1.4: change your password
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2. Topologies

2.1 Concepts

For hynesim, a topology is a virtual network architecture.

It is made of entities that make it possible to simulate the behavior of an information system in order to produce

realistic architectures either for testing, prototyping or training.

2.1.1 Loaded/Unloaded topologies

By default, a topology is unloaded. When this is the case, all entities within this topology are free to be used anywhere

else. When you open a topology, this one becomes loaded and locks all its entities.

Tip: Since an entity can only be used in one topology at a time, clone it to be able to reuse it.

2.2 Create, open and run topologies

2.2.1 Creating a new topology

To create a new topology, go to File → New Topology (Shortcut: CTRL+N).

Figure 2.1: create a new topology from the menu

If you’re on the topology dialog already, which should be the default after connecting, you can press the “New topol-

ogy” button at the bottom left of the window.
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Figure 2.2: create a new topology from the topology dialog

You are then able to choose the size of the topology area before creating it. This size is not definitive and can be

changed later on. It’s only used to set a limit to the topology size.

Figure 2.3: topology creation options

2.2.2 Opening a topology

To open an already existing topology, go to File → Open Topology (Shortcut: CTRL+O). This opens the topology catalog

window. This window is the one opened by default when you connect.
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Figure 2.4: open the topology dialog

You can then pick the topology that you want to load. On this menu you can also import, export, clone or delete

topologies with the buttons on the right of the window (or a right click).

Figure 2.5: topology catalog window

When the topology opens, you can add the entities you want and navigate freely inside it. Right click is used to move

around and you can interact with the different entities by clicking on them.
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Figure 2.6: topology view

2.2.3 Navigation between topologies

You can navigate between opened topologies with the drop down menu on the left of the toolbar or with the Opened

Topologies widget.

Figure 2.7: change focused topology

Figure 2.8: opened topologies dock widget

2.2.4 Saving a topology

To save your topology go to File → Save topology as… (Shortcut: CTRL+SHIFT+S) to create a new save file after giving it

a name.
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Figure 2.9: save a new topology

If you already created the topology before, just select File → Save (Shortcut: CTRL+S) to overwrite the last save.

Figure 2.10: saving a topology

2.3 Topology properties and statuses

2.3.1 The different topology statuses

In the topology menu, you can see the different statuses of topologies defined by an icon in the top right corner:

This icon indicates that the topology is open and running.

This icon indicates that the topology is not visible but still running in the background. This state can

only be achieved if the topology is set as persistent.
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This icon indicates a problemwith the topology. Some entities used in the topologymust have been

removed. You can perform a right click → fix to remove missing entities from the topology to be

able to open it.

2.3.2 Unloading a topology

Unloading a topology means forcing a topology to close for all users. It will shut down every entity in the topology

immediately and then close the topology. This is the only way to really close a persistent topology.

Figure 2.11: unloading a topology

Note: Unloading a topology that hasn’t been saved is the same as removing it.

2.3.3 Accessing topology parameters

You can also access the properties of your topologies from the same menu.

Figure 2.12: accessing a topology’s properties

You can change the name and add a description, as well as seeing details about your topology :
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Figure 2.13: some details about a topology

To make the topology persistent (i.e keep it loaded when closed), check the box in the Options tab.

Figure 2.14: topology options

2.3.4 Cloning a topology

You can clone (copy) a topology by right clicking on it and then clicking “Clone”.
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Figure 2.15: cloning a topology

Awindowwill openwith a fewoptions. You can clone the topologymultiple times by changing the “Number of clones”

spinbox and rename every topology invidually. For explanations about the clone type, see section “Linked clones”

Figure 2.16: topology clone options

2.3.5 Removing a topology

You can remove a topology from your catalog by right clicking on it and then clicking “Delete” or pressing the delete

button.
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Figure 2.17: removing a topology

2.3.6 Fixing a topology

If your topology is broken for any reason, you can try fixing it by right clicking on it and then clicking “Fix”.

Figure 2.18: fixing a topology

Warning: Fixing it will remove any entities that aren’t available anymore from the topology.

2.3.7 Exporting a topology

To export a topology, you first need to unload it. You can then right click on it and click “Export”.

Figure 2.19: exporting a topology
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This will open a new panel in the topology catalog window with a few options for the export. You can compress

entities (this will slow down the export a lot), you can name the exported topology and you can make it a tar (this will

also slow down the export).

Figure 2.20: topology export options

Once the export is finished, it will be available on the platform at /data/hynesim/export.
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3. Entity catalog

3.1 Concepts

Each element in a topology is called an entity. There are currently 6 different types of entities which will be described

in this section.

Entities can be connected to others using wires. Wires can be selected in the toolbar, depending if you want straight

wires (Shortcut: W), wires with one angle (Shortcut: 1) or wires with two angles (Shortcut: 2). When you want to go back

to selecting, click on the mouse icon (Shortcut: ESC).

3.1.1 The different statuses

Entities have different states that are used to describe their state inside the topology :

Undefined: In this state, the entity doesn’t exist in the simulation. This is the default state for any entity.

Defined: This state is achieved by defining an entity. When an entity is in this state, it is provisionned on a node and

its network interfaces are ready.

Running: The entity is currently running.

Sleep: The entity is hibernating, corresponding to a Linux suspend command or Windows sleep mode.

Paused: The entity is frozen. Any actions or processes that were running are paused until the entity is resumed.

Saved: The entity is frozen as if it was in pause state, but its image is saved on the disk, meaning that it will keep its

state even if the node is removed.

Busy: The entity is currently switching between two states.

To change the state of an entity, you can right click on it or use the toolbar on the top right corner.

Figure 3.1: the different entity actions

3.2 The different types of entities
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3.2.1 Domains

Figure 3.2: a domain in a topology

Domains are entirely customizable virtual machines. You can set them up with any type of hardware.

For detailed explanations about the properties of virtual machines, see section “Virtual machines properties”. The

detailed VM creation guide can be found in section “VM creation”.

Remote display

Once the virtual machine is started, you can access its remote display (Shortcut: RETURN) with a double click to open

in a new tab.

Note: If you open a remote display while someone else has already opened one for the same entity, yours will be on

read-only.

Right clicking on a tab gives you the options:

• fullscreen will open the tab as a new fullscreen window,

• detach will open the tab as a new window

• reattach will reattach the current tab to the main window. It is only available in detached windows

• send keys allows you to send special combinations of keys that would otherwise be caught by the host machine

(e.g. ctrl+alt+suppr)

• take R/W access will put everyone else that has the remote display opened as read only and you as read/write

Figure 3.3: the different remote display actions
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3.2.2 Switch

In hynesim, there are two different switch implementations:

• The native switch relies on Linux bridges and doesn’t support advanced options (STP, VLANs)

• The Open vSwitch one relies on an external service and supports these options

Figure 3.4: The two types of switch, open vSwitch on the right

In the system parameters you can define the behavior (switch or hub) and the number of ports of your entity as well

as the implementation of the switch. If the switch is an open vSwitch you can also add a mirror port.

Figure 3.5: switch network parameters

If the switch is an open vSwitch one, you can configure VLANs for your switch in the VLAN tab.

To add a VLAN, simply click Add a new VLAN and the following window opens.
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Figure 3.6: adding a VLAN

After typing a name and validating, your entry will appear in the list.

Figure 3.7: VLAN list

Double click on your entry to setup the ports associated with that VLAN. Click Ok once you’re done. To delete a VLAN,

click the bin icon on the right.
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Figure 3.8: VLAN assignment

3.2.3 Hybrid Netcard

Figure 3.9: a hybrid netcard in a topology

The hybrid netcard can be used to connect your virtual topology with a real network.

Add the hybrid card to your topology, then instantiate and start the hybrid card. Plug the real hardware you want to

integrate to your topology on the corresponding physical port (contact your network administrator). Your hardware has

access to and can be accessed from the topology.

You can change the node and the physical plug it’s associated to in the entity preferences.
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Figure 3.10: hybrid netcard preferences

3.2.4 Topology Gate

Figure 3.11: a topology gate in a topology

The topology gate is an entity that allows you to connect multiple topologies. You can think of them as “distributed

switches”. All the topology gates with the key name will be connected together. You can change said key in the entity

preferences.

Figure 3.12: topology gate properties

Tip: A common practice with the topology gate is to connect it with an hybrid netcard with internet access. This way you
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only need one netcard to get internet in any number of topologies.

3.2.5 Data Diode

Figure 3.13: a diode in a topology

This entity exclusively allows for a unidirectional communication between two entities, which can, depending on the

orientation, allow an impossible access (security) or an impossible extraction (confidentiality). However, this concept

breaks most communication protocols (i.e. ARP, TCP/IP), and so it needs a specific configuration on each side of the

diode. Statistic entries in the ARP table are for instance necessary to establish communication.

The arrows on the wires connected to the diode indicate the direction of the allowed traffic.

3.2.6 Wi-Fi access point

Figure 3.14: a wifi AP in a topology

Awifi access point allows you to emit a real wifi network via a physical card. It acts otherwise like a hybrid cardmeaning

that hardware connected to it will have access to the topology where the access point is wired.

To set it up, go to the Network tab. This is where you can define your access point SSID, its MAC address, the channel

it uses, as well as the type of authentication and the password used if necessary.
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Figure 3.15: a wifi AP properties

Tip: We recommend using a real hardware wifi access point with a hybrid card instead of that entity. They’re way more

reliable and powerful.

3.2.7 Wires

A wire is a link between two entities. It’s the only way to get network connectivity between two entities in a topology.

Wire properties apply according to the orientation of traffic (right to left or left to right), which makes it possible to

simulate an asymmetrical connection. The left and right side are arbitrary and you’ll have to check which entity it’s

referring to at the bottom of the window.

There are a few properties you can change on a wire:

• Delay: Add a delay in the given direction (in ms)

• Loss: Add a loss of packets in the given direction (in %)

• Dup: Add a packet duplication chance in the given direction (in %)

• Bandwidth: Limit the bandwidth in the given direction (in kB/s)

• MTU: Limit the MTU in the given direction (in bytes)

A 0 means that it’ll take the default value which is what you would expect from a perfect wire.
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Figure 3.16: a wire properties

The interfaces the wire is connected to are visible in the properties and when you select or hover over them, depend-

ing on the action selected in the HMI preferences (see section “Hyneview global settings”).

3.2.8 Common properties

All entities have 2 common tabs in their properties. The General tab lets you name the entity and add a description

and/or tags.

Figure 3.17: general properties
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The Details tab displays some information about the entity: name, UUID, creation date, architecture if it’s a VM, etc.

Figure 3.18: entity details

Tip: This tab is where you can get the UUID of an entity if you need it.

3.3 Catalog Organization and management

You can manage your entities using the entity catalog on the left side of the topology area. To display/hide it go to

View → entity catalog.

Figure 3.19: show/hide the entity catalog

The entity catalog is a tree listing all entities the user can see. You can organize it with folders and clone, delete, edit

and share entities. To add an entity to a topology, simply drag and drop it.
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Figure 3.20: entity catalog

To add a folder, right click on the catalog root or another folder if you want to create a subcategory. You can then drag

and drop entities inside your folder.

Figure 3.21: Adding a folder

You can also use the icon at the top of the widget.

Figure 3.22: Adding a folder

3.3.1 Entity Operations

Cloning entities

You can enrich your catalog by cloning entities. For this, you can do a right click → Clone or click the icon at the top of

the entity catalog.

Figure 3.23: clone an entity from the contextual menu
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Figure 3.24: clone an entity

This will open a new window allowing you to choose a few parameters for the clone action.

Figure 3.25: entity clone parameters

In this window you can choose a few things:

• the type of clone you want, either full or linked (see section “Linked clones”)

• the number of clones

• the name of every cloned entity

• the destination folder

• the destination entity catalog

• whether to randomize MAC addresses or not

Entities affected by the clone are locked in the catalog and are given an animated loading icon to mention that some-

thing, namely a clone is being processed. Entities being currently cloned also display the percentage of completion of

the process.

Figure 3.26: an entity being cloned
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Note: The number of clones that can be simultaneously executed is defined in the master configuration (for more infor-

mation, contact your administrator). This only limits the number of simultaneous clones, not the number of clone you

can execute. If you require more clones than the limit, they will simply be put in a queue.

Removing entities

To delete an entity, select the catalog entries (entity and/or folder) you want to delete and right click → Delete (Shortcut:

DEL).

Warning: If you delete a folder without selecting all its entities, ALL entities inside will be moved to the parent folder.

Figure 3.27: deleting an entity

3.3.2 Linked clones

A linked clone generates an entity derived from the cloned entity. So, there is a parent entity A and an entity A’ for

which only the changes made since the clone will be stored. The disk image of entity A is the basis for the disk image of

entity A’ and it must not be changed. Therefore, entity A can no longer be used in a topology. Entity A, which is parent

to the linked clone, is displayed with a “P” icon in the catalog, which indicates that entities are linked to it. Such entities

are displayed with the “C” status icon. If an entity is linked, it cannot be deleted from the catalog, since it would make

its children unusable.

Figure 3.28: a linked clone in the catalog

To find children derived from an entity, you only must select the parent entity and click the icon in the toolbar.
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Figure 3.29: finding all related entities

A parent entity, although unusable due to aforementioned reasons, can still be cloned, no matter the cloning mode.

Child and parent can be unlinked by rebasing the child disk on the parent disk. To do so, click the Rebase button in the

toolbar or right-click the child entity and select the corresponding action (you will still keep the original child).

Figure 3.30: rebasing an entity

You can delete entities with a right click → Delete. The entity cannot be a parent of a linked clone and must not be

locked.

3.4 Import and Export

3.4.1 Import

To import new entities go to Tools → import and select the « Entities » tab.

Figure 3.31: importing an entity

The importable entities must be in the /data/hynesim/import folder on the platform. Contact you administrator to

get access.
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Select the entity and the path you want to use, click Import and they will be added to the catalog.

Figure 3.32: importing an entity

You can also import the entity multiple times and give different rights to each one allowing for quick distribution of

machines to different users.

Note: The only supported format is the one used by hynesim. You won’t be able to import an entity from another virtual

machine manager directly.

3.4.2 Export

To export a virtual machine, go to right click → Export. Exported VMs can be found at /data/hynesim/export on

the platform. Ask you administrator for access.

Figure 3.33: exporting an entity
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Note: If the entity is a linked clone, it will be rebased before being exported so that it’s a standalone entity.

3.5 Virtual machines properties

3.5.1 Hynesim related configuration

In the Hynesim tab, you can find useful options that hynesim can provide:

• Specific node key (Explained here in subsection 5.8)

• A shared folder between the VM and your machine accessible at /data/hynesim/share (see 5.5)

• Toggle Immutability (Shortcut: I): Immutable puts the disk image of a virtual machine in a kind of read-only mode.

An immutable virtual machine works like a normal machine. However, when it is shut down, all the data that has

been written to the disk is discarded. An immutable entity is displayed with the icon when used in the topology.

Note: if you need to save changes to an immutable VM, you can use the button Commit immutable changes on

the toolbar.

• A serial port for the action manager

• Toggle template mode: When a template-type entity is placed in a topology, a copy of it is instantiated and the

entity is locked only for the duration of the copy. The resulting entity in the topology is a clone of the template at

the given moment.

Figure 3.34: hynesim specific properties
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3.5.2 Motherboard related configuration

In the Motherboard tab, you can set up everything related to the CPU and RAM and hypervisor features.

• Machine: Used to control the qemu -machine argument. Leave empty unless you really know what you’re doing.

• Architecture: The architecture of the virtual machine. Read only for now.

• vCPU: The number of cores to allocate for that virtual machine.

• ACPI: Whether or not to enable ACPI in the virtual machine. Leave checked unless you know you need it to be off.

• PAE: Whether or not to enable PAE in the virtual machine. Leave checked unless you know you need it to be off.

• APIC: Whether or not to enable APIC in the virtual machine. Leave checked unless you know you need it to be off.

• Mimic node CPU: Tell QEMU to expose the same capabilities to the machines as the host CPU. This can help with

performances in some cases and is required to expose virtualization capabilities.

• Expose virtualization capabilities will allow you to run virtual machines inside your virtual machine.

• Memory: The RAM to allocate for that virtual machine.

Figure 3.35: motherboard related properties

3.5.3 Date/Time configuration

TheDate/Time tab allows you to specify thetime reference to beused for the virtualmachine (onlyworks for KVM/QEMU

domains). You have a few options here:

• UTC: The RTC of the virtual machine will contain the UTC time of the host.

• Local time: The RTC of the virtual machine will contain the local time of the host.

• Offset: The RTC of the virtual machine will contain the UTC time of the host plus or minus an offset.
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• Manual: The RTC of the virtual machine will contain the specified time.

Note: The RTC will be set on start of the virtual machine.

If the time is important to you in the topology, you should set every linux machine to UTC and windows machine to

localtime to avoid having time issues. This is required due to the difference in the interpretation of the RTC between linux

and window.

Figure 3.36: date/time properties

3.5.4 Boot configuration

The Boot tab allows you to define the priority of different peripheral devices in the starting sequence.

The kernel, initrd and command line properties are for advanced use cases and allow booting the virtual machine

directly to a specific kernel with custom parameters. It is also possible to specify if you want to display a selection menu

for the concerned device when the machine is started (only for KVM/QEMU domains).

The behaviour here is to boot to the first disk unless something is checked in the list of bootable peripherals. If multiple

peripherals are checked then they’ll be tried in the order they are in the list.

You can also choose between booting with UEFI or the Legacy BIOS.

Warning: Changing this will break the current booting setup. It should only be chosen at the machine creation unless

you know what you’re doing.
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Figure 3.37: boot configuration

3.5.5 CD-ROMs configuration

The CD-ROMs tab allows you to add one or more CD-ROM drive(s) to the virtual machine, which can optionally have a

loaded ISO (only for KVM/QEMU domains).

Every CD can be booted on if necessary.
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Figure 3.38: CD-ROM configuration

Tip: You can change an ISO while a domain is running allowing you to hotswap CD-ROMs

3.5.6 Network configuration

In the Network tab, you can add network interfaces by clicking the + button andmodify their characteristics (model, type,

MAC address).
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Figure 3.39: Network configuration

Warning: Unless you really need performances, use the e1000 netcard. If you do need performances, use a virtio netcard

but be aware that it has a few quirks. For example it doesn’t compute any checksum which breaks protocols, such as

DHCP.

Warning: The order displayed in hynesim might not be respected by the operating system in virtual machine, especially

if you have different types of netcard.

3.5.7 Keyboard configuration

In the Keyboard tab of LXC domains, you can change the layout of the keyboard. This is only available for LXC containers

for which it should match your keyboard layout for it to work properly.
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Figure 3.40: Keyboard configuration

3.5.8 USB redirection configuration

In the USB tab, you can add USB ports to your VM. (See section “USB Redirection”)
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Figure 3.41: USB redirections

3.5.9 Video configuration

In the Video tab, you can change the video card of the VM.

Tip:

By default you should set it to QXL unless it’s causing any troubles.

This document is the sole and exclusive property of DIATEAM and may not be duplicated or distributed without its consent.

STRICTLY CONFIDENTIAL - DISCLOSURE FORBIDDEN

Page 38/74



HYNESIM PRO USER GUIDE, version 3.0

VERSION 2.0

HNS-HYNESIM-PRO-3.0-UserGuide-2.0-EN

Figure 3.42: video configuration

3.5.10 Disk configuration

The Disk tab provides a read-only view of the disk images associated to a virtual machine.
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Figure 3.43: disk configuration
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4. User Rights management

4.1 User and group management

Hynesim implements a user/group systemused tomanage permissions. By default, there are 2 users and 2 groups: admin

and hns (attached to groups of the same name). The admin user has the highest level of rights and can manage other

users.

To access the user management, go to Window→ User Manager.

Figure 4.1: accessing the user manager

On the tab, you can switch between users, groups and API keys. Users and groups can be created, cloned, edited or

deleted with a right click or using the toolbar.

Figure 4.2: managing users and groups

4.2 User rights management

You can filter the access to an entity/topology with a right click → Rights.
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Figure 4.3: accessing rights

The window that opens allows you to share the selected entities/topologies with other users/groups. To do that,

choose the target you want to share it with and click on the share button.

If you selected multiple entities before opening the right window, you can either change rights tab by tab or if you

want to apply the same rights to all of them, click the “Apply to all” button and then validate the window.

Figure 4.4: managing rights

Note: For an entity to appear in someone’s catalog, the user should have the rights on all the parent folders of said entity.

Note: Giving rights on a topology doesn’t automatically give rights on the entities inside. Those should be given sepa-

rately if needed.
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5. Advanced Features

5.1 Booting on an ISO

5.1.1 ISO catalog

To use an ISO in a virtual machine, you first need to upload it to the master. For that you’ll need to use the ISO manager.

Figure 5.1: accessing the ISO manager

You can upload an ISO from your local computer by clicking on the “Add” button. The ISO will then appear greyed out

with a progress. Once it’s done you’ll be able to use it.

Figure 5.2: the ISO manager

5.1.2 Booting on the ISO

In a KVM/QEMU properties, in the CD-ROMs tab, add a CD with the plus button on the top right. You can then choose

the source ISO and the bus type (IDE should work most of the time).
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Figure 5.3: choosing an ISO

Last step before starting the VM, go to the Boot tab and check the CD-ROM containing your ISO.

Figure 5.4: choosing the boot order
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Tip: If you’re installing an operating system, don’t forget to uncheck the ISO in the boot menu or remove the CD ROM

slot so you don’t boot on the installation ISO again.

5.2 USB Redirection

Hynesim allows you to redirect the connection of a USB device through the spice remote display protocol.

You can define the number of devices which can be redirected, as well as the controller type (default: USB 1.0) in the

properties of the virtual machine, on the “USB” tab. (see section “USB Redirection”)

Start the VM and activate the remote display. You can then activate USB redirection from the toolbar or with a right

click → USB redirection.

Figure 5.5: redirecting a USB device

Warning: The remote display MUST be open to access USB redirection.

You then are prompted to the list of all your USB connected device. Check the one you want to redirect, then click

on Apply. The redirected device is highlighted in green. The device is then accessible inside the VM.

Figure 5.6: USB redirection window

An entity with an active USB redirection will have this icon added above its name:

Figure 5.7: USB redirection icon

5.3 Network Capture

Hynesim makes it possible to capture network packets on any interface of an entity.

To open the network capture window, right click on an entity → Capture job.
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Figure 5.8: opening the network capture manager

To launch a network capture, select the network interface you want to capture network on.

Figure 5.9: starting a network capture

You can set a few options:

• Time limit: The capture will run for the specified number of seconds and then stop automatically.

• Packet limit: The capture will stop after getting the specified number of packets.

• Filter: BPF filters applied to the capture.

Click on start to actually start the capture. A new entry appears in the network capture manager table showing you some

information about the running capture.

An entity with an active network capture will have this icon added above its name:

Figure 5.10: network capture icon
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You can then either click on “View” or double click on a running capture to open a wireshark instance showing you

captured packets in real time.

Note: You need rights to capture packets for this to work.

You can also click on the download capture to open a non updating file. To stop a running capture, just click on the

stop button after selecting the capture to stop in the table. To delete a network capture, select the capture you want to

remove from the table and click Delete.

5.4 Memory dump

It’s possible to create memory dumps of your virtual machine with a right click → Display Memory dumps. For that, the

machine needs to be defined or started.

Figure 5.11: accessing memory dumps

You can create a dump by typing a name for it and then clicking on the create button.

Once you created a dump, you can export it by selecting it and clicking Download destination of the dump.

5.5 File Sharing

You can easily share files with your KVM/QEMU machines equipped with a GNU/Linux operating system. Activate file

sharing in the properties of your virtual machine: Properties → Hynesim.
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Figure 5.12: activating file sharing

This will allow you to mount the master’s /data/hynesim/shared folder inside the virtual machine. Contact your

administrator to be granted access to the directory of the platform.

For a QEMU-type machine, open a terminal and execute the following command:

mount -t 9p -otrans=virtio hynesim-shared [mount-point]

For a LXC container, the directory can automatically be accessed in /mnt/hynesim-shared.

5.6 Load Balancing

Hynesim is equipped with a utility that makes it possible to balance calculation load between the different servers that

compose the platform. On a topology with multiple entities, click the Load balancing button in the toolbar.

Figure 5.13: accessing the load balancer

The load balancer window opens.

You can see the current state of your platform on the right. On the left is the list of entities you can define in the

topology. Check all the entities you wish to use at the same time, you can choose the nodes for each entity or leave it on

auto to let hynesim do the best thing for you, then click “Compute” and you can see the estimation of the nodes on the

right.
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Figure 5.14: load balancer window

Note: The displayed load is an estimation and not the real one. Check the platform monitor to see the real state of the

platform.

The estimated load is indicated in the right part and the allocation sites of each entity are listed in the table.

Figure 5.15: the estimated cost of defining the entities

Note: Machine definition is only effective when the window has been validated.

Tip: You almost never want to use this window. By default hynesim defines entities in a smart way to balance the load

between nodes.
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5.7 Snapshots

Snapshots are used to keep a saved instance of a virtual machine.

5.7.1 Creating snapshots

To create a new snapshot, you can right click → Create snapshot.

Figure 5.16: creating a new snapshot

A new window opens asking you to give your snapshot a name. You can then click on “Create”.

Figure 5.17: creating a new snapshot

Note: The VM must be defined but not running.
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5.7.2 Managing snapshots

You can find and manage all your snapshots with a right click → Snapshot manager.

Figure 5.18: accessing the snapshot manager

The snapshot manager opens. In this window you can also create a new snapshot or remove one but more impor-

tantly, you can revert your virtual machine to a saved state. You can do so by clicking the “Revert to” button after selecting

the state you’re intrested in.

Figure 5.19: reverting to an older snapshot

Tip: Snapshots are organized in a tree, you can have multiple states deriving from one.

Warning: Snapshots currently don’t work with EFI domains due to a limitation in QEMU.
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5.8 Associating an entity to a given node

To ensure that an entity will always be attributed to the same node, you only need to indicate its key in the properties

window, in the Hynesim tab of the entity.

Figure 5.20: setting a node key on an entity

You almost never want to use this unless you need some kind of hardware capabilities or have a lot of network trafic

going between two virtual machines.

5.9 Adding wires to the catalog

You can add wires in the catalog to have model wires which properties are saved. Right-click a wire in your topology and

select Add to catalog in the menu. Name your wire and click “ok”.
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Figure 5.21: adding a wire to the catalog

To add the newly created wire to a topology, click and drag the wire from the catalog to the topology, as for any other

entity.

Note: Wire color not being a property of the wire, but only a display detail, it is only saved in the topology. The model

wire does not store any color.
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6. Customization

6.1 Topology and entity scope

6.1.1 Topology customization

To modify the layout of the topology, click the Layout icon in the toolbar.

Figure 6.1: accessing the topology layout

In the window that opens, you can modify the width, height and change the background color by clicking on the

palette, or add a background image by clicking on the 3 dots icon. The Clear button removes the topology background

image.

Figure 6.2: the topology layout window

Once you’re done, click OK and the topology will update itself.

6.1.2 Wire customization

Colors

To change the color of a wire, do a right click → Change wire color.
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Figure 6.3: accessing wire color selection

A new window opens asking you to select a color for the wire. Once you click ok, the wire will be of the color you

chose.

Figure 6.4: some colored wires

You can also change the default color for all new wire, by clicking on the “Default wire color” in the toolbar.

Figure 6.5: changing the default wire color

Shape

To change the number of angles of an existing wire, right click on the wire and select the desired option in the pop-up

menu.
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Figure 6.6: changing the number of angles in a wire

To do this for all the future wires, click on the desired option in the toolbar.

Figure 6.7: changing the default wire angle number

6.1.3 Entity customization

You can change the icon of any entity with a right click → Set custom graphics.

Figure 6.8: accessing the custom graphics window

To upload an icon, click on Add a new Icon and select your file. Once you added and/or chose the file you want to

use as your custom icon, you can click Apply.
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Figure 6.9: changing the custom graphics of an entity

If you want to reset the icon to the classic Hyneview one, just click on “Restore Defaults”.

6.1.4 Other customization

There are a few other customization options for hyneview:

• Show labels: Allows you to hide the label of every entity in the topology

• Show status: Allows you to hide the status of every entity in the topology

• Grid mod: Make every entity dragged on the topology snap to a grid

Figure 6.10: accessing other customization options

6.2 Hyneview global settings

The options window makes it possible to define default behaviors for the application, topologies and remote screens.

To access hyneview global settings, go to File → Options.
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Figure 6.11: accessing hyneview global settings

In the main tab, you can choose to save the window size on exit or change the password generator settings.

Figure 6.12: main hyneview settings

The topology related settings are a bit more interesting. You can change default colors, enable the grid mode all the

time and enable the display of ports numbers on wires on hover for example.

Figure 6.13: topology hyneview settings

In the remote display settings you can choose to detach all the remote display by default.
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Figure 6.14: remote display settings

6.3 Dockable widgets

Hyneview uses dockable widgets that you can move around and detach. You can attach them inside the main window

on the left and on the right for all of them except the logs which can be attached at the top or the bottom. Here’s a list

of all the widgets:

• Entity Catalog

• Opened topologies: makes it possible to switch to a topology by double-clicking its name or to close it using the

cross that is displayed when hovering over it

• Topology overview: displays the global visual representation of the current topology

• Topology content: displays the list of entities in the topology by definition node

• Monitoring: displays information about the selected virtual machine if enabled in the master configuration.

• Logs: display events and messages sent by hynesim. You can filter them by clicking on the blue buttons at the top.

To display/hide them go to View and select a widget. You can also reset the default view which will restore every

widget to its default position.

Figure 6.15: changing the displayed dock widgets

6.4 Screenshot & Printing

You can take a screenshot of a full topology or just a few entities. Go to File → Screenshot.

• The Screenshot option captures the entire topology even if it’s bigger than what’s displayed.
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• Screenshot selection only captures entities you selected.

• Screenshot current view captures what your topology screen is currently displaying.

Saved screenshots can be found in /home/Hyneview/Images.

Figure 6.16: creating a screenshot of a topology

It’s possible to directly print a topology or a selection. To do so, go to File → Print.

Figure 6.17: printing a topology
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7. VM creation

Since we can both create empty virtual machines and boot on a CD-ROM, we can create virtual machines from scratch

without ever leaving hyneview. In this section we’ll see how to do that.

7.1 Creation guide with hyneview

To begin with, download the ISO of the desired OS on your computer.

Tip: If you plan to create a Windows VM using a virtio disk, you also need to download an ISO containing the required

drivers IN ADDITION of the Windows ISO: http://www.linux-kvm.org/page/WindowsGuestDrivers/Download_
Drivers

You can now go to Tools → Create a new entity and select Domain.

Figure 7.1: creating a domain in the entry maker
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In the General tab, name your entity and click next to the Motherboard tab, where you can change the number of

vCPU and Memory size as you want.

Figure 7.2: CPU/RAM configuration

Click next to the Disk tab and add at least one disk (“+” button) to install the OS. You can change the size and the bus

type (sata, virtio, or others).
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Figure 7.3: adding disks to the new entity

Click next to the Network tab and add a network card if you need one by clicking on the ‘+’ button. Don’t forget to

change the model to a virtio if you need to.
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Figure 7.4: adding disks to the new entity

Click next to the CD ROMs tab and add a disk to load your ISO on. You can select your ISO on the source line.
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Figure 7.5: adding disks to the new entity

Note: If you plan to use a Windows VM with a virtio disk, you will need to add a second disk for the ISO containing

the drivers that you downloaded earlier. Click next to the Boot tab and check the CD-ROM containing your ISO in the list.
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Figure 7.6: adding disks to the new entity

Proceed to the last tabs to setup last options. Once everything is done, you’re ready to start your entity and follow

the setup instructions of your ISO.

When the install is done, before restarting your VM to access the freshly installed OS, open the properties of your

entity and uncheck the CD-ROM containing your ISO in the Boot tab(or you can completely remove the CD slot in the CD

ROM tab) or the virtual machine will restart the install again.

Additional steps for a virtio Windows VM:

After starting your VM, you are prompted to the windows setup. Follow the standard installation procedure unti you

arrive on the disk screen.

Windows will tell you that it cannot find any disk. Click on the “add driver” button.
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Figure 7.7: installing windows

Click on Browse.

Figure 7.8: loading virtio drivers

Select the folder containing the drivers (here: virtio-win/amd64/w10).
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Figure 7.9: loading virtio drivers

Click Ok and finish the installation.
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Figure 7.10: finishing the windows installation

Don’t forget to remove the ISOs from your VM once the setup is done.

This document is the sole and exclusive property of DIATEAM and may not be duplicated or distributed without its consent.

STRICTLY CONFIDENTIAL - DISCLOSURE FORBIDDEN

Page 69/74



HYNESIM PRO USER GUIDE, version 3.0

VERSION 2.0

HNS-HYNESIM-PRO-3.0-UserGuide-2.0-EN

7.2 LXC containers

You can run LXC containers inside hynesim.

7.2.1 Prerequisites

Note: All manipulations must be made as root. This tutorial was made for Debian 10.

We’ll start by installing the required tools.

apt install lxc uuid-runtime
updatedb

7.2.2 Create the container

To create a container, we’ll use the standard way of doing so with lxc-create. Note that there are other templates, you

can refer to the ‘lxc-create‘ documentation to find them. We’ll use the debian template which requires having access to

valid debianmirrors. Another commonly used one is the ‘download‘ template which downloads a premade rootfs to use.

lxc-create -t debian -n entity_name

If you want another os and have internet, you can use this command instead and choose the OS in the menu that

opens.

lxc-create -t download -n entity_name

7.2.3 Enable autologin (optionnal)

Note: This is not the right way to access a container filesystem. We can only do that because it’s not started yet

Create the file autologin.conf inside the container.

mkdir -pv /var/lib/lxc/entity_name/rootfs/etc/systemd/system/getty@tty1.service.d/
vim /var/lib/lxc/entity_name/rootfs/etc/systemd/system/getty@tty1.service.d/autologin.conf

Write the following code inside

[Unit]
ConditionPathExists=
ConditionPathExists=-/dev/tty

[Service]
ExecStart=
ExecStart=-/sbin/agetty --autologin root --noclear %I 38400 mach
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Start the container and attach you shell to it. This will allow us to manipulate its system configuration.

lxc-start entity_name
lxc-attach entity_name

Start the getty service.

systemctl enable getty@tty1.service

Finally, disable the service console-getty.service. If you don’t, the LXC container will flicker in hynesim and will con-

nect/disconnect you in a loop.

systemctl mask console-getty.service

You can now exit (CTRL+D) and stop the container

lxc-stop entity_name
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7.2.4 Hynesim configuration

Warning: Make sure your LXC container is stopped before doing any of the following. You can check with ‘lxc-ls -f‘

To get the container to behave correclywhenhyneview resizes its output, weneed to create the following file Formore

details, see: https://unix.stackexchange.com/questions/16578/resizable-serial-console-window/283206#
283206

vim /var/lib/lxc/entity_name/rootfs/etc/profile.d/resize

You need to put the following code inside:

old=$(stty -g)
stty raw -echo min 0 time 5

printf '\0337\033[r\033[999;999H\033[6n\0338' > /dev/tty
IFS='[;R' read -r _ rows cols _ < /dev/tty

stty "$old"

stty cols "$cols" rows "$rows"

Now make it executable:

chmod +x /var/lib/lxc/entity_name/rootfs/etc/profile.d/resize

7.2.5 Hynesim entity creation

We’ll start by moving all the required files into a single directory.

mkdir entity_name && cd entity_name
mv /var/lib/lxc/entity_name/rootfs ./
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Create a file called hnsEntryConfig.xml and add the following content.

Change the shortName field to match your entity name

vim hnsEntryConfig.xml

<!DOCTYPE HnsEntityConfig>
<HnsEntityConfig version="1.1">

<Header longName="LXC" description="LXCDescription" creationDateTime="1302194226"
shortName="entity_name" lastModificationDateTime="1415352775891"/>
<Entity customGraphic="" isModel="0" isTemplate="0" saved="0">

<domain actionmanagerinterface="-1" type="lxc">
<vcpu>1</vcpu>
<memory>262144</memory>
<os>

<type arch="x86_64">exe</type>
</os>
<features>

<pae/>
<apic/>
<acpi/>

</features>
<devices netcardAutoId="0">

<filesystem type="mount">
<source dir="rootfs/"/>
<target dir="/"/>

</filesystem>
<interface description="" type="bridge" id="0">

<mac address="00:1c:a7:db:c9:f5"/>
<source bridge="eth0"/>

</interface>
<graphics keymap="fr"/>

</devices>
<metadata>

<metadatamap/>
</metadata>

</domain>
<domainsnapshots current=""/>

</Entity>
</HnsEntityConfig>

Move your folder in the hynesim import folder

cd ..
mv entity_name /data/hynesim/import/
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Inside hyneview, go to Tools → Import, select your entity in the list and import it

Figure 7.11: the LXC inside the import window

Your LXC will now appear in the entity catalog, and is treated the same as other entities.

Figure 7.12: the LXC inside the entity catalog
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